'. '


From APIDesign

(Difference between revisions)
Jump to: navigation, search

TimBand (Talk | contribs)
(Improvement suggestions)
Next diff →

Revision as of 13:21, 24 October 2008

Accessor could perhaps be called ItemAccessor (living in ItemAccessor.java)? This makes it more obvious that you have to write this boilerplate for each class needing the back door. TBa

It would be nice to be able to put in extra comments without cluttering up the text. Hovers would be ideal, but I guess not supported by this Wiki (and not in the code section anyway). Is there any way of doing footnotes? The particular point is the line l = listener in Item.java. This is presumably so that in the presence of multiple threads, an "obslete" listener may be called, but you will never get a null pointer exception. That's too much to clutter the code with, but it spent quite a bit of my effort working it out. TBa

Should all the "default"s really be called "default"? aren't we really talking about TheAccessor or something? TBa

It is much clearer setting the DEFAULT directly than the book's indirect classloader method, but now shouldn't setDefault be synchronized? TBa

Personal tools