'. '

Evolution of an API is Different to the Evolution of an SPI

From APIDesign

(Difference between revisions)
Jump to: navigation, search
(New page: Page 126, code example: <tt>convertChar</tt> is a very bad name for the function -- it doesn't hint what the method does. Suggest calling <tt>rot13</tt> instead of <tt>convertChar</tt>. Yo...)
Line 1: Line 1:
 +
Page 124, <tt>CountingWriter</tt> code example: <tt>@author</tt> tag probably not needed.
 +
Page 126, code example: <tt>convertChar</tt> is a very bad name for the function -- it doesn't hint what the method does. Suggest calling <tt>rot13</tt> instead of <tt>convertChar</tt>. You don't even need to list the code for <tt>rot13</tt>, a comment above the line where you call it should be enough for those readers who haven't encountered this algorithm yet.
Page 126, code example: <tt>convertChar</tt> is a very bad name for the function -- it doesn't hint what the method does. Suggest calling <tt>rot13</tt> instead of <tt>convertChar</tt>. You don't even need to list the code for <tt>rot13</tt>, a comment above the line where you call it should be enough for those readers who haven't encountered this algorithm yet.

Revision as of 13:49, 8 April 2008

Page 124, CountingWriter code example: @author tag probably not needed.

Page 126, code example: convertChar is a very bad name for the function -- it doesn't hint what the method does. Suggest calling rot13 instead of convertChar. You don't even need to list the code for rot13, a comment above the line where you call it should be enough for those readers who haven't encountered this algorithm yet.

Page 126, para -2: typo in BufferedReader.writer(String).

Page 129: weird formatting of write(char cbuf[]) and write(String str). This code example also uses arr and cbuff interchangeably, please consider consistently using a single name.

The example is perhaps a bit too long. Considering that you made it up, are all those overloaded write methods necessary?

Page 131: the parameter of create(ImplSeq impl) should be named seq for the sake of consistency.

--AndreiBadea 13:46, 8 April 2008 (UTC)

Personal tools
buy