JaroslavTulach: Talk:Separate APIs for Client APIs and Support APIs moved to Talk:Separate APIs for Clients and Providers: Adjusting to the title in the printed version of the book - 2008-08-14 08:16:30

Talk:Separate APIs for Client APIs and Support APIs moved to Talk:Separate APIs for Clients and Providers: Adjusting to the title in the printed version of the book

←Older revision Revision as of 08:16, 14 August 2008

Apidesign: New page: '''Done: 9da22fb3cc94''' The name of the chapter doesn't make any sense to me. How about "Separating APIs into Client API's and Service Provider API's"? Page 120, para 2: "WinAmp" shoul... - 2008-06-14 05:59:01

New page: '''Done: 9da22fb3cc94''' The name of the chapter doesn't make any sense to me. How about "Separating APIs into Client API's and Service Provider API's"? Page 120, para 2: "WinAmp" shoul...

New page


'''Done: 9da22fb3cc94'''

The name of the chapter doesn't make any sense to me. How about "Separating APIs into Client API's and Service Provider API's"?

Page 120, para 2: "WinAmp" should be "Winamp".

--[[User:AndreiBadea|AndreiBadea]] 13:22, 8 April 2008 (UTC)

'''Done: 4b040ec30843'''


Page 121: <tt>xmms_register_playback</tt> should take a <tt>(void)(*f)(char*)</tt> parameter (note the order of <tt>*</tt> and <tt>f</tt>). Moreover, the parentheses around <tt>void</tt> are superfluous.

Page 121, para -1: "call back" should perhaps be "callback".

--[[User:AndreiBadea|AndreiBadea]] 13:29, 8 April 2008 (UTC)


'''Done: cc4e959ec9de'''


Page 124, <tt>CountingWriter</tt> code example: <tt>@author</tt> tag probably not needed.

Page 126, code example: <tt>convertChar</tt> is a very bad name for the function -- it doesn't hint what the method does. Suggest calling <tt>rot13</tt> instead of <tt>convertChar</tt>. You don't even need to list the code for <tt>rot13</tt>, a comment above the line where you call it should be enough for those readers who haven't encountered this algorithm yet.

Page 126, para -2: typo in <tt>BufferedReader.writer(String)</tt>.

Page 127, code example: no apparent reason for the <tt>(csq != null && csq.length() < 1024)</tt>. Yarda says it is because the <tt>BufferedWriter</tt> needs to buffer. In that case, perhaps moving the test to a <tt>shouldBuffer</tt> method or similar would be more transparent.

Page 129: weird formatting of <tt>write(char cbuf[])</tt> and <tt>write(String str)</tt>. This code example also uses <tt>arr</tt> and <tt>cbuff</tt> interchangeably, please consider consistently using a single name.

The example is perhaps a bit too long. Considering that you made it up, are all those overloaded <tt>write</tt> methods necessary?

Page 131: the parameter of <tt>create(ImplSeq impl)</tt> should be named <tt>seq</tt> for the sake of consistency.

--[[User:AndreiBadea|AndreiBadea]] 13:46, 8 April 2008 (UTC)

# Pages 129-132: Code samples were long and was difficult to know exactly what I should be looking for.

--[[User:TomWheeler|TomWheeler]] Sat Apr 12 19:13:37 CDT 2008


'''Done: 70c0c4836a28'''

Page 134, para -2: "masterfs" will only make sense to NetBeans developers. Why not use "master filesystem" instead?

--[[User:AndreiBadea|AndreiBadea]] 13:52, 8 April 2008 (UTC)

Page 133: The first sentence is a very concise summary of the difference between API and SPI. You should consider also using it in the previous section when you introduce the concept.

Page 133: Kirk Knoernschild "Java Design" book does an excellent job of explaining the importance of packages in Java. Maybe you should reference it here, since you touch on the same subject.

--[[User:TomWheeler|TomWheeler]] Sat Apr 12 19:13:37 CDT 2008